Prompts for Azure MFA when an admin attempts to access Microsoft Admin Portals

Incident Report for ITS System Status

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 14:25 EDT

Monitoring

A fix for our PROD environment has been implemented and we are monitoring results.
Posted Apr 01, 2025 - 12:13 EDT

Identified

A change recently implemented by Microsoft has been identified as the root cause of this issue. We have implemented a fix in our QA environment and are monitoring results.
Posted Apr 01, 2025 - 11:24 EDT

Investigating

We have received reports of admins being prompted for Azure MFA enrollment when attempting to access Azure and M365 admin portals. Our team is currently investigating. In the meantime, if you're an admin and you need timely access to an admin portal, you may enroll into Azure MFA to work around this issue.
Posted Mar 31, 2025 - 11:10 EDT
This incident affected: Email Systems (UTMail+).