MS Forms: Update sync for Group-owned forms issue

Incident Report for ITS System Status

Update

Microsoft Forms Product Group is targeting a fix for March 24th.
Posted Mar 17, 2025 - 11:51 EDT

Identified

We have received an update that Microsoft Forms Product Group is aware of the problem and is actively working on it.
Posted Mar 05, 2025 - 11:18 EST

Update

The issue has been escalated to the Microsoft Critical Situation Management Team.
Posted Feb 25, 2025 - 15:45 EST

Update

Microsoft is continuing to investigate the issue with the Group Forms Update Sync.
Posted Feb 19, 2025 - 11:54 EST

Investigating

Microsoft Forms recently changed how it syncs with Excel.
Some group form owners reported they can't update to the new sync.
We've reported the issue to Microsoft and will share an update soon.
Posted Feb 05, 2025 - 13:12 EST
This incident affects: Email Systems (Office 365).