Microsoft Services
Incident Report for ITS System Status
Resolved
Microsoft has completed their mitigation actions and their telemetry indicates all previously impacted Microsoft 365 apps and services have recovered. Microsoft will monitor to ensure impact is fully resolved.
Posted Jul 19, 2024 - 11:39 EDT
Monitoring
ITS is aware of the major outage to Microsoft 365 infrastructure. Core University services do not appear to be directly impacted at this time. We will continue to monitor as the situation evolves.
Posted Jul 19, 2024 - 08:36 EDT
This incident affected: Email Systems (Office 365).