Acorn Service Issue
Incident Report for ITS System Status
Resolved
The ACORN issue has been resolved and all services restored.
We apologize for the inconvenience caused.
Posted Jul 26, 2024 - 11:45 EDT
Investigating
We are investigating reports of users not being able to access the ACORN service.
Please be assured that we are aware of the problem and we have technical staff looking into it.
Posted Jul 26, 2024 - 11:24 EDT
This incident affected: Student Web Services (ACORN).