Course Evals: degraded service
Incident Report for ITS System Status
Resolved
The issue has been resolved and service restored. Thank you for your patience.
Posted Dec 04, 2024 - 07:41 EST
Investigating
The Course Evaluations service is experiencing unplanned and intermittent service interruptions. Support engineers are working to restore the service to full operation. Please try again momentarily.
Posted Dec 03, 2024 - 12:53 EST
This incident affected: Student Web Services (Course Evaluations).