Bell link to UTSC down.
Incident Report for ITS System Status
Resolved
The Bell link to UTSC issue has been resolved and all services have been restored.
We thank you for your patience.
Posted Jul 15, 2024 - 07:23 EDT
Investigating
The Bell link to UTSC campus is down and the vendor crew is investigating. We will provide updates as they become available.
Posted Jul 12, 2024 - 13:03 EDT
This incident affected: Campus (UTSC).