Some individuals may be unable to access Outlook on the web in UTMail+ (https://mail.utoronto.ca)

Incident Report for ITS System Status

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 16:00 EDT

Identified

Microsoft has identified the root cause and is currently working on reverting a code change.
Posted Mar 19, 2025 - 15:27 EDT

Investigating

We have received reports of some individuals being presented with a "something went wrong" error when trying to logon to Outlook Web Access in UTMail+ (https://mail.utoronto.ca). We are currently investigating this issue and provide an update in 30 minutes.
Posted Mar 19, 2025 - 14:40 EDT
This incident affected: Email Systems (Office 365).