Self Service Password Reset - Service Change
Incident Report for ITS System Status
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 15:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2024 - 17:52 EDT
Identified
Information Security will apply an emergency fix against a recently-detected issue at the SSPR platform starting at 2 pm today, April 4. We expect the process take approximately 10 hours. No interruption of service is expected.
Posted Apr 04, 2024 - 10:57 EDT
This incident affected: Identity Management Systems (Self-Service Password Reset).